Zoom Security Upgrade Requires Installation of New Client by May 30 | Information Technology | University of Pittsburgh
!

Zoom Security Upgrade Requires Installation of New Client by May 30

Friday, May 22, 2020 - 14:55

 

On May 30, Zoom is implementing a stronger form of encryption that provides enhanced protection for meeting data. To enable these security enhancements, Zoom is requiring all users to upgrade to version 5.0 of the Zoom client by May 30.

After May 30, older versions of Zoom clients will be required to upgrade before they can be used to start or join a Zoom meeting.

You can learn more about Zoom on the Pitt Information Technology website.

Please contact the 24/7 IT Help Desk at 412-624-HELP (4357) if you have any questions regarding this announcement.