Box to End Support for TLS 1.0 on June 15, 2018 | Information Technology | University of Pittsburgh
!

Box to End Support for TLS 1.0 on June 15, 2018

Friday, June 1, 2018 - 08:38

 

Box has announced that it is ending support for TLS 1.0 on June 15, 2018. Therefore, all Box applications, web browsers, and third party applications must support TLS 1.1 and higher to access Box after June 15. TLS is a protocol that helps to provide privacy between applications that communicate with one another.

Please keep in mind the following:

  • Recent versions of web browsers already support TLS 1.1 and higher. If you are using an older web browser, you should upgrade to the latest version.
  • The latest versions of Box Tools, Box Sync, Box for Office, and Box Drive support TLS 1.1 and higher. If you use one of these applications, please be sure you are using the latest version. In general, these applications should automatically upgrade to the latest version.

Additional information is available on Box’s website.

Please contact the Technology Help Desk at 412 624-HELP [4357] if you have any questions about this announcement.